Multiviews not allowed in shared hosting

  1. 2 years ago

    Hi,

    last week i tested to install into shared hosting environment, but install is not working. After that i contacted the helpdesk of hosting provider, specs are fine , so i sent them the log file. the log files showed us, multiviews not allowed?
    this is the message in logfile:

    [Thu Jan 08 20:13:14 2015] [alert] [client 86.95.165.19] /sites/postmastersalkmaar.nl/opdrachten/.htaccess: Option MultiViews not allowed here

    The hosting provider is not going to enable this, so is there an option to by pass this? So i can install into shared hosting environment?

    Regards,
    Rene

  2. chintan

    15 Jan 2015 Administrator

    please change your .htaccess file to the following code:

    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
    
        # Redirect Trailing Slashes...
        RewriteRule ^(.*)/$ /$1 [L,R=301]
    
        # Handle Front Controller...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
  3. Hi, I have the same problem with the school's server. Although I changed the .htaccess file as listed above, the web page throws a 404 not found and the log file says a 304 error.

    I'm trying to fix this problem before talking to the school's system admin since he is quite busy.

    If you have any other suggestion, could you please let me know?

    Thanks in advance.

    Terry

  4. chintan

    17 Jan 2015 Administrator

    @TerryKLin

    Could you please remove the line of multi views from your .htaccess file and see if that works. Also check that mod_rewrite is enabled if you are using apache.

    Please let me know if that works.

    Thanks,
    Chintan

  5. Hi Chintan,

    I've removed the multi views line and mod_rewrite is enabled. However, when I'm trying the access the application using the URL, it gives me a "Sign in" page. The problem is, I don't have an account, and when I clicked the "Click to restore" link, it throws a 404 not found page.

    Could you please let me know where I did wrong?

    Thank you,

    Terry

  6. chintan

    21 Jan 2015 Administrator

    @TerryKLin

    You need to install the app. Go to http://[your app url]/install to begin the installation wizard.

  7. Hi Chintan,

    i updated .htacces file with code above;
    checked the write permissions in given folders/files:

    when i call the url http://opdrachten.postmastersalkmaar.nl/install
    it shows me the error you find below:

    Not Found
    The requested URL /install was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    and when i call the url without 'install' like this http://opdrachten.postmastersalkmaar.nl/ its show me

    Sign In, please!
    "email field" + "password field"
    Sign In
    Forgot password? Click here to restore
    © 2014 92five app

    Thanks for your reply :)

  8. i found this line in the error log (after update .htacces file)

    Wed Jan 21 20:17:40 2015] [error] [client 86.95.165.19] File does not exist: /sites/postmastersalkmaar.nl/opdrachten/errors, referer: http://forums.92fiveapp.com/?p=78-multiviews-not-allowed-in-shared-hosting

  9. chintan

    24 Jan 2015 Administrator

    @drukspook

    Have a look at http://opdrachten.postmastersalkmaar.nl/92fiveapp/index.php/install You .htaccess needs to change so that you don't have to put index.php in the url

 

or Sign Up to reply!