Installation problem after the database credentials form

  1. 2 years ago

    Ubuntu 14.04, PHP 5.9, Apache 2.4, MySql 5.5

    After I fill the credential details and submit the form, I get this message:

    Oops !Something Went Wrong.
    Something went wrong and we have noted that. Thank you for understanding.Go back to Dashboard ?

    I enabled the debug messages, but there isn't any additional info.

  2. Also, far less important, but the text that appears in the textfield for username says "usernmae"

  3. chintan

    11 Aug 2014 Administrator

    @trevanian Please follow the following steps

    1. Open the file app/controllers/InstallController
    2. Delete the line no 39 which will be 'connections.mysql.prefix' =>$data['prefix'],
    3. Start over

    Let me know if you still having problems in installation

  4. That line doesn't exist:

    $newDbConfig->toFile(app_path().'/config/database.php', [
    'connections.mysql.host' =>$data['host'],
    'connections.mysql.database' =>$data['database'],
    'connections.mysql.username' =>$data['username'],
    'connections.mysql.password' =>$data['password'], //This is the line number 39
    ]);

  5. chintan

    11 Aug 2014 Administrator

    @trevanian please grant writing permission to app/config/app.php, app/config/database.php and app/config/92five.php

  6. Edited 2 years ago by tkl

    Having exactly same problem.

    Everything should be ok on my end (tried both on virtual server running debian and XAMPP install on windows) . I have also tried both from the zip and latest version from github.

    I can see that app/config/database.php gets changed with my provided information.

    1. Open the file app/controllers/InstallController

    1. Delete the line no 39 which will be 'connections.mysql.prefix' =>$data['prefix'],
    2. Start over

    Doesn't help either.

    Any tips where to go now?

  7. chintan

    24 Aug 2014 Administrator

    @tkl
    To analyse the error could you perform the following steps and let me know where exactly error you are getting. These steps will enable Laravel's default error reporting tool:

    1. Set debug flag to true in app/config/app.php
    2. Comment line 110 - 113 in app/start/global.php i.e.

    App::error(function(SomeThingWentWrongException $exception, $code) { return Response::view('errors.somethingwentwrong', array('subject'=>'Project'),400); });

    changes to

    /*App::error(function(SomeThingWentWrongException $exception, $code) { return Response::view('errors.somethingwentwrong', array('subject'=>'Project'),400); });*/These steps will show you the error your are facing instead of usual something went wrong page.
    Please let me know what is the error and we can take it further from there...

  8. Sorry forgot to say that I have tried setting debug mode on as did @trevian.

    But still, I get the red background colored error page instead of the very simple error page which occurered when I didn't have php-gd installed. This happens right after submitting database credentials form.

  9. chintan

    24 Aug 2014 Administrator

    @tkl Try step 2 on my previous comment and let me know what exact error you are facing. Step 2 will disable the red error page and will enable the laravel's error page.

  10. Still seeing the red error page.
    Tried with steps 1 and 2.

    Tried with only step 2.

  11. chintan

    24 Aug 2014 Administrator

    @tkl Can you post the screen shot of the error you are getting ?

  12. http://imgur.com/EpF01Oh

    I'm using self signed CERT on my VPS. tried without SSL also.

  13. chintan

    24 Aug 2014 Administrator

    @tkl please check app/global/start.php and make sure that you have comment out the line 110-113. If you have commented those line you wont see this page. Please check again the file.

  14. Edited 2 years ago by tkl

    Solved.

    For to see debug messages I had to comment out lines 110-118, not 110-113 , so the code was:

    /*App::error(function(SomeThingWentWrongException $exception, $code)
    {
                  return Response::view('errors.somethingwentwrong', array('subject'=>'Project'),400);   
    });
    App::error(function(Exception $exception, $code)
    {   
        return Response::view('errors.somethingwentwrong', array('subject'=>'Project'),400);   
    });*/

    Then I could see that "PDOException could not find driver" occured, though the installer's first checks said that PDO is enabled. What fixed that was installing php5-mysql package (debian wheezy)

    Thanks.

  15. I did it this way to enable a readable output when the debug option is on. .
    Or compressed put the above eight lines in this conditional:

    if(Config::get('app.debug') == false) {
  16. chintan

    8 Jan 2015 Administrator

    @fraank Cheers mate. Could you l please make the PR for the same in the github repo ? Other users also needs to use it.

    Thanks.
    Chintan

 

or Sign Up to reply!